http://gamingtrend.com
November 28, 2014, 08:52:02 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Calendar Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: Network/Workgroup Password Help  (Read 2269 times)
0 Members and 1 Guest are viewing this topic.
Eco-Logic
Gaming Trend Member
Gaming Trend Senior Member

Offline Offline

Posts: 3004


Gamertag: St0ckBroker


View Profile
« on: October 27, 2004, 09:33:42 PM »

Here at my work we have a medium sized network.  We all share a T1 connection and have access to a Copier/Printer.  

My team has 5 computers, with my computer having the only CDRW.  We use a backup program that has a template given to us by the home office.  I need to run backups bi-weekly for all the computers on our team.  I understand that the way to accomplish this is to share the C drive on the other 4 computers, map to them on my computer, re-create a template for each of the drives and run each template bi-weekly.  My problem is I have no idea how to make the drive secure once I share it.  For example, I shared the financial analyst's C drive just now by right clicking on C and clicking the sharing tab, selecting "share this folder on the network" & "Allow Network Users to Change my Files".

I came back to my computer and mapped her drive just fine.  I don't know where the option to put a password on it would be and I haven't had much luck with windows help.  It talks about a Strong Password, but doesn't really tell how to go about doing it.  She does have to enter a password when she logs onto the computer.  Also, even though I shared her entire C drive, when I click on the program files within her C Drive it tells me I don't have permission to access that drive.  Any idea what is going on or how to fix it?  Thanks in advance for any help.
Logged

Wake up.
Eco-Logic
Gaming Trend Member
Gaming Trend Senior Member

Offline Offline

Posts: 3004


Gamertag: St0ckBroker


View Profile
« Reply #1 on: October 27, 2004, 09:35:59 PM »

Looks like I may have just found the info I need:

"To set, view, change, or remove file and folder permissions
Open Windows Explorer, and then locate the file or folder for which you want to set permissions.
Right-click the file or folder, click Properties, and then click the Security tab.
Do one of the following:
To set permissions for a group or user that does not appear in the Group or user names box, click Add. Type the name of the group or user you want to set permissions for and then click OK.
To change or remove permissions from an existing group or user, click the name of the group or user.
Do one of the following:
To allow or deny a permission, in the Permissions for User or Group box, select the Allow or Deny check box.
To remove the group or user from the Group or user names box, click Remove.
 Important

If you are not joined to a domain and want to view the Security tab, see To display the Security tab.
 Notes

To open Windows Explorer, click Start, point to All Programs, point to Accessories, and then click Windows Explorer.
In Windows XP Professional, the Everyone group no longer includes Anonymous Logon.
You can set file and folder permissions only on drives formatted to use NTFS.
To change permissions, you must be the owner or have been granted permission to do so by the owner.
Groups or users granted Full Control for a folder can delete files and subfolders within that folder regardless of the permissions protecting the files and subfolders.
If the check boxes under Permissions for user or group are shaded or if the Remove button is unavailable, then the file or folder has inherited permissions from the parent folder. For more information on how inheritance affects files and folders, see Related Topics.
When adding a new user or group, by default, this user or group will have Read & Execute, List Folder Contents, and Read permissions.
For more information about permissions on other objects, see Permissions.

Related Topics
"
Logged

Wake up.
Eco-Logic
Gaming Trend Member
Gaming Trend Senior Member

Offline Offline

Posts: 3004


Gamertag: St0ckBroker


View Profile
« Reply #2 on: October 27, 2004, 09:38:15 PM »

Actually, that doesn't work for me.

The only thing I see about security is under sharing and it's for local sharing.  

There is no security option under Network Sharing and Security frown
Logged

Wake up.
Biyobi
Gaming Trend Senior Member

Offline Offline

Posts: 718


View Profile
« Reply #3 on: October 27, 2004, 09:43:17 PM »

What operating system are you running on the various workstations?  Do you log into a domain or workgroup server?
Logged
egrudzin
Gaming Trend Reader

Offline Offline

Posts: 199


View Profile
« Reply #4 on: October 28, 2004, 03:05:54 AM »

If you have XP Home I don't think you get a Security tab or anything.  You have to have XP Pro to set permissions on a per file/folder basis.

You may also have to turn off Simple file sharing in XP Pro to get security to work.  Go to Folder Options under the Control Panel and click the View tab.  Scroll to the bottom of the list and uncheck the box "Use simple file sharing" and click OK.  You should then get a security tab on file and folder property windows.
Logged
Zimix
Gaming Trend Senior Member

Offline Offline

Posts: 669



View Profile
« Reply #5 on: October 28, 2004, 03:28:18 AM »

Make sure the drive is formated NTFS.  Otherwise you can't set security at the folder/file level.

To check this double click on My Computer, select the drive, right click on it, and go to properties.  
Under File System: Does it say NTFS or FAT32?

If it is FAT32, you can convert it to NTFS by going to a command prompt (Click on Start, Run, type in CMD, click on OK)

Now type
convert drive: /fs:ntfs

Replace drive: with your drive letter.  So if you are wanting to convert
your C: drive, issue the following:

convert c: /fs:ntfs
Logged
Eco-Logic
Gaming Trend Member
Gaming Trend Senior Member

Offline Offline

Posts: 3004


Gamertag: St0ckBroker


View Profile
« Reply #6 on: October 28, 2004, 02:08:17 PM »

We're all running Windows XP Professional and all drives are NTSF.
Logged

Wake up.
Eco-Logic
Gaming Trend Member
Gaming Trend Senior Member

Offline Offline

Posts: 3004


Gamertag: St0ckBroker


View Profile
« Reply #7 on: October 28, 2004, 02:09:40 PM »

Quote from: "egrudzin"
If you have XP Home I don't think you get a Security tab or anything.  You have to have XP Pro to set permissions on a per file/folder basis.

You may also have to turn off Simple file sharing in XP Pro to get security to work.  Go to Folder Options under the Control Panel and click the View tab.  Scroll to the bottom of the list and uncheck the box "Use simple file sharing" and click OK.  You should then get a security tab on file and folder property windows.


Awesome.  That opened up the security tab.  Thanks a ton for the info.  Now I just have to figure out what to do smile
Logged

Wake up.
egrudzin
Gaming Trend Reader

Offline Offline

Posts: 199


View Profile
« Reply #8 on: October 29, 2004, 01:34:54 AM »

What you can do is create your user account on the other PCs.  Then open the security properties for the folders on the other PCs and give your account access (as well as the actual user of the PC).  You can remove all other users from the permissions on that folder to keep others out.  Realize that any user that is an Administrator on that machine can open that folder whether they have rights to it or not (since they can just give themselves rights).  This is a quick explaination, let me know if it's not clear.
Logged
Purge
Gaming Trend Staff
Gaming Trend Senior Member

Offline Offline

Posts: 18616



View Profile WWW
« Reply #9 on: October 29, 2004, 01:41:48 AM »

Quote from: "Eco-Logic"
Actually, that doesn't work for me.

The only thing I see about security is under sharing and it's for local sharing.  

There is no security option under Network Sharing and Security frown


First you need to disable simple file sharing.
From an explorer window :
1) tools - folder options
2) select views tab
3) scroll to the bottom
4) remove checkmark from simple file sharing.

Now you're playing with power.
You can right-click on the folder or drive to share, and select sharing and security.
click on the New Share button and create a new share with the desired name.
Don't touch the one above (C$) it's an admin share and you shouldn't bother mucking with it.

You can also create a local group in the manage option for windows.
Right click my computer and select manage.
Click on local users and groups, and create a group called Driveshare
You can also create id's for the co-workers and set up passwords.
Add the users to the Driveshare local group.
Then go to the properties of your shared folder and give the appropriate permissions to the Driveshare group.
If only one person should be able to change content, then repeat the group creation with something like driveshareModify or something, and add them to it as well.
Give the Drivesharemodify the enhanced permission on the share, and they will inherit the better permissions, even though they are in both groups.

I'll spell this crap out if ya need it, I'm too tired to do it right now.

Now everyone should have a username and password, belong to the Driveshare group(s), and the drive has been shared and Driveshare group(s) have been given appropriate permissions. Get the other users (while logged into their machine to map the drive, and be sure to have them enter Computer\username where computer is the destination PC, and the username is the one you created for them.

Someone above mentioned using NTFS file permissions, and you are welcome to do so. I'd advise using groups on the share for security.
It's not a good idea to use the admin shares for users, so you're going to have to worry about administering share permissions anyways... no need to lock it twice. Plus, since we're talking about the drive itself if they ever log into your PC natively (from your desk) they could have a hard time depending on the NTFS permissions granted to them. To add the NTFS (file level) permissions might be taking it farther than you need to, and it can add a whole new layer of complexity with conflicting rules.

Since you may go this way, I might as well give you an idea as to how it works :

User over network Permissions= (Share permission(s) ) + (File Permission (s) ). Between the share and file permissions you always get the most restrictive based on the combination of both.

Basically, if you have L_User who needs to get to Server\Share\Folder1, and the Folder1 gives them Read/Write and Share gives them Read Only, they get Read Only. If it's reversed, it's the same thing. The R/W permission of the share is pointless as the directory is going to force read only, so they effectively only have Read.

If they belong to two groups and either the share or the folder includes both groups, they will gain the better of the two. using the example above:
L_User is part of Driveshare (read only on share, full access on NTFS)
L_User is ALSO part of Driveshare modify (read/write on share, full access NTFS)
L_User gets Read/Write on that share, as the combination of share permissions is (at best) R/W. The file permissions are FULL access, but the Share restricts it to only R/W.

And one other thing, do NOT use deny permissions. That can really mess you up unnecessarily. Deny permissions take precedence over allow permissions.        

PM or email me if you need assistance. Like I said, I'm tired right now, so I'm kinda jumping all over.
Logged

"If it weren't for Philo T. Farnsworth, inventor of television, we'd still be eating frozen radio dinners." - Johnny Carson
Eco-Logic
Gaming Trend Member
Gaming Trend Senior Member

Offline Offline

Posts: 3004


Gamertag: St0ckBroker


View Profile
« Reply #10 on: October 29, 2004, 09:43:08 PM »

Thanks Purge, I'm about to get off work but I have bookmarked this and will return to it on Monday.  Awesome info smile
Logged

Wake up.
Purge
Gaming Trend Staff
Gaming Trend Senior Member

Offline Offline

Posts: 18616



View Profile WWW
« Reply #11 on: November 02, 2004, 05:09:39 PM »

Eco, how did that work out for ya?
Logged

"If it weren't for Philo T. Farnsworth, inventor of television, we'd still be eating frozen radio dinners." - Johnny Carson
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines
Valid XHTML 1.0! Valid CSS!
Page created in 0.12 seconds with 47 queries. (Pretty URLs adds 0.022s, 2q)