http://gamingtrend.com
October 22, 2014, 04:08:48 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Search Calendar Login Register  
Pages: [1]   Go Down
  Print  
Author Topic: question regarding Titan Quest  (Read 736 times)
0 Members and 1 Guest are viewing this topic.
WorkingMike
Gaming Trend Reader

Offline Offline

Posts: 350


View Profile
« on: December 09, 2006, 09:35:04 PM »

so, I finally got around to playing Titan Quest, and it's pretty cool, but I'm getting pretty questionable performance. I'm running an AMD dual core 4200, a 7900gt card, 2 gigs of ram and a Creative X-fi for sound.

The problem is stuttering. I set everything at medium, with Vertical Sync set on(otherwise I get some weird ghosting on my LCD). I installed the dual core optimizer that AMD put out, and that helps a little, but I still get random slowdowns and stuttering. It's definitely playable, but kinda aggravating, especially because I feel that my system should be able to handle it with everything close to max.

Anyone have anything similar happen or have any ideas?
Logged
Thin_J
Gaming Trend Senior Member

Offline Offline

Posts: 3409


View Profile
« Reply #1 on: December 09, 2006, 10:14:45 PM »

Titan Quest slows down on my Core 2 Duo E6400 (oc'd to 2.7ghz), 2gb DDR2-800, SLI 7900GTO system.

It's not that there's anything wrong with your computer, it's just that the game's engine is a pig. Seriously.

I mean sure it's pretty.. but there's nothing there that justifies the generally mediocre performance that even people with monster gaming systems get.

Wait until you get to the third act. There's some areas in there where lots of transparency kills game performance if you run in any reasonably high resolution.
Logged

Xbox Live: Thin J
PSN: Thin_J
WorkingMike
Gaming Trend Reader

Offline Offline

Posts: 350


View Profile
« Reply #2 on: December 09, 2006, 10:28:18 PM »

ah well, that sucks, but at least it's playable. Now if they just work out the kinks in NWN2, i'll dive into that one.

Thanks for the info smile
Logged
whiteboyskim
Senior Staff Writer
Gaming Trend Senior Member

Offline Offline

Posts: 7848


Hard partier


View Profile
« Reply #3 on: December 09, 2006, 10:30:06 PM »

Immediately turn off shadows. In the readme for the last patch I believe it's in there. You have to add a line to the .ini file but it's very easy to do and will help performance. There are other performance tweaks right here among other issues.

Like Thin said though the engine is ass.
Logged

Behold the glory of my new blog!
Filmmaking is vision plus faith plus balls, all 3 of which Hollywood knows little about.
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines
Valid XHTML 1.0! Valid CSS!
Page created in 0.076 seconds with 30 queries. (Pretty URLs adds 0.018s, 2q)